This forum is currently locked. You can't register or post questions at this time. (read more)

Probelm in starting Apache

All posts relating to Oracle database administration.

Moderator: Tim...

Guest

Probelm in starting Apache

Postby Guest » Mon Nov 01, 2004 6:09 pm

Hello,

I am facing problem in starting Apache of 9iAS all of a sudden today. It was working fine till last week. and nobody changed the ports any port setting etc

'apachectl start' gives the message that its started properly
'netstat -a | grep 7777' also shows that the port is now in use

But the home page doesnt get opened in browser

error_log shows the following error message
The env variables (ORACLE_HOME, LD_LIBRARY_PATH and PATH etc) are all correct

[Mon Sep 27 06:36:17 2004] [crit] (4)Interrupted system call: Unable to initialize Oracle OCI
[Mon Sep 27 06:36:17 2004] [error] (4)Interrupted system call: Please check your enviroment.
ORACLE_HOME is [/export/ias/9ias]
LD_LIBRARY_PATH is [/export/ias/9ias/lib:/export/ias/9ias/lib]
WV_GATEWAY_CFG is [/export/ias/9ias/Apache/modplsql/cfg/wdbsvr.app]
NLS_LANG is [Not Set]
[Mon Sep 27 06:36:17 2004] [notice] caught SIGTERM, shutting down

Please let me know what the probelm could be

Thanks

Guest

RE:Probelm in starting Apache

Postby Guest » Mon Nov 01, 2004 6:09 pm

The IP address is static, not DHCP address.
Checked env variables (several times)

Unable to hit the cause..

Please let me know

Waiting for your reply Tim

Thanks

Tim...
Site Admin
Posts: 18437
Joined: Mon Nov 01, 2004 5:56 pm
Location: England, UK
Contact:

RE:Probelm in starting Apache

Postby Tim... » Mon Nov 01, 2004 6:09 pm

Hi.

The "Unable to initialize OCI" message sounsd interesting. Have you tried connecting to your database from the application server using SQL*Plus to see if there is a problem here?

Check the normal network configuration issues (ping and tnsping) and see what that give you.

Cheers

Tim...
Tim...
Oracle ACE Director
Oracle ACE of the Year 2006 - Oracle Magazine Editors Choice Awards
OakTable Member
OCP DBA 7.3, 8, 8i, 9i, 10g, 11g
OCP Advanced PL/SQL Developer
Oracle Database: SQL Certified Expert
My website: http://www.oracle-base.com
My blog: http://www.oracle-base.com/blog

Guest

RE:Probelm in starting Apache

Postby Guest » Mon Nov 01, 2004 6:09 pm

Hello Tim,

Thanks for the update
But why are we trying to do this ?

sqlplus of AS_ORA_HOME/bin is giving some probelm. But this was always the case
And the Apache started giving problem from today only

[ias@nawab bin]$ pwd
/export/ias/9ias/bin
[ias@nawab bin]$ ./sqlplus
ERROR:
ORA-01821: date format not recognized


SP2-0152: ORACLE may not be functioning properly

SQL*Plus: Release 8.1.7.0.0 - Production on Mon Sep 27 08:53:57 2004

(c) Copyright 2000 Oracle Corporation. All rights reserved.

[ias@nawab bin]$


ping and tnsping are giving the expected result

Tim...
Site Admin
Posts: 18437
Joined: Mon Nov 01, 2004 5:56 pm
Location: England, UK
Contact:

RE:Probelm in starting Apache

Postby Tim... » Mon Nov 01, 2004 6:09 pm

Hi.

I was doing this because of the "Unable to initialize Oracle OCI" error. I wanted to know if there was a connectivity issue. It appears there is not.

It's not apparrent from the error messages what the issue is so I'm not sure I can help. It's probably a good idea to log a TAR with Oracle as they will be able to tell you what to try to get more logs out.

Cheers

Tim...
Tim...
Oracle ACE Director
Oracle ACE of the Year 2006 - Oracle Magazine Editors Choice Awards
OakTable Member
OCP DBA 7.3, 8, 8i, 9i, 10g, 11g
OCP Advanced PL/SQL Developer
Oracle Database: SQL Certified Expert
My website: http://www.oracle-base.com
My blog: http://www.oracle-base.com/blog


Return to “Oracle Database Administration”

Who is online

Users browsing this forum: No registered users and 4 guests

cron