This forum is currently locked. You can't register or post questions at this time. (read more)

Some DADs not working

All posts relating to Oracle database administration.

Moderator: Tim...

Guest

Some DADs not working

Postby Guest » Mon Nov 01, 2004 6:09 pm

Hello,

I am trying to create/use DAD (data access descriptors)
Apache is running OK. Home page is getting accessed
Some of the DADs are working OK, while some are not

(a)
This URL works - http://192.168.239.36:7777/pls/portal31 ... _procedure
Following is displayed as expected :
Procedure - portal31_procedure
Schema - portal30
Home page of portal31 DAD

(b)
This URL doesnt work - http://192.168.239.36:7777/pls/portal30/portal30.home
Following is displayed
The page cannot be found

(c)
This URL doesnt work - http://192.168.239.36:7777/pls/portal30 ... _procedure
Following is displayed
The page cannot be found

(c)
This URL also doesnt work - http://192.168.239.36:7777/pls/portal30 ... tal30.home
I am getting "Forbidden. You don't have permission to access /pls/portal30_dup/portal30.home on this server"


All the attributes - authentication mode, schema, host string etc in DAD descriptions are same for portal30, portal30_dup and portal31 DAD

case (b) : I verified several times that "home" procedure is valid in portal30 schema
case (c) : Why "portal31_procedure" gives the probelm when it is working in case (a) and the schema is the same - PORTAL30 ?
case (d) : What is it forbidden ?

The error_log (and also access_log) of Apache doesnt show anything helpful

Please help

Tim...
Site Admin
Posts: 18437
Joined: Mon Nov 01, 2004 5:56 pm
Location: England, UK
Contact:

RE:Some DADs not working

Postby Tim... » Mon Nov 01, 2004 6:09 pm

Hi.

I can't claim to be an expert on portal, becuase I'm not, but my portal installation only uses a single DAD "/pls/portal". I'm not sure why yours has multiples, or even if it should.

I suggest you open a TAR with Oracle support to investigate it further.

Cheers

Tim...
Tim...
Oracle ACE Director
Oracle ACE of the Year 2006 - Oracle Magazine Editors Choice Awards
OakTable Member
OCP DBA 7.3, 8, 8i, 9i, 10g, 11g
OCP Advanced PL/SQL Developer
Oracle Database: SQL Certified Expert
My website: http://www.oracle-base.com
My blog: http://www.oracle-base.com/blog

Guest

RE:Some DADs not working

Postby Guest » Mon Nov 01, 2004 6:09 pm

Thanks for the update Tim

No, all these DADs didnt come with the installation.
I have created these, just to diagnose that problem lies with all DADs (and procedures) or only "portal30" DAD and "home" procedure that its home page calls

I was searching your forum and found a couple of threads wherein you have mentioned the possible causes of "Page cannot be found"
(the thread is - http://www.oracle-base.com/forum/ReadMe ... =1&id=2334)

I verified those. The procedure "home" is valid. It doesnt take any parameters. It has "when others" exception section that doesnt throw the exception

Tim...
Site Admin
Posts: 18437
Joined: Mon Nov 01, 2004 5:56 pm
Location: England, UK
Contact:

RE:Some DADs not working

Postby Tim... » Mon Nov 01, 2004 6:09 pm

I really don't know what you are trying to get at. Ignore all you extra DADs you've added. Why don't you start at the begining and tell me what you think is wrong, not what you've done to diagnose it. Something like:

"I believe this portal URL (http://......) should work but it doesn't. Here's the error message I'm seeing (......). Have you got any ideas?"

That seems like a logical place to start to me!

Cheers

Tim...
Tim...
Oracle ACE Director
Oracle ACE of the Year 2006 - Oracle Magazine Editors Choice Awards
OakTable Member
OCP DBA 7.3, 8, 8i, 9i, 10g, 11g
OCP Advanced PL/SQL Developer
Oracle Database: SQL Certified Expert
My website: http://www.oracle-base.com
My blog: http://www.oracle-base.com/blog

Guest

RE:Some DADs not working

Postby Guest » Mon Nov 01, 2004 6:09 pm

dear all,

i need help.I am using oracle 10g application server on redhat paltform.i tried to config DAD to use PLSQL.i followed all the steps provided by Oracle_base website how to configure the DAD.my problem is,the error occured when i want to complete the configuration.for information,i config the DAD thru portal.this is the error:

500 Internal Server Error
javax.servlet.ServletException at oracle.sysman.emSDK.svlt.EMServlet.doGet(EMServlet.java:294) at oracle.sysman.eml.app.Console.doGet(Console.java:152)at oracle.cabo.servlet.UIXServlet.doPost(Unknown Source)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:760) at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
at com.evermind[Oracle Application Server Containers for J2EE 10g (9.0.4.0.0)].server.http.ServletRequestDispatcher.invoke(ServletRequestDispatcher.java:778) at com.evermind[Oracle Application Server Containers for J2EE 10g (9.0.4.0.0)].server.http.ServletRequestDispatcher.forwardInternal(ServletRequestDispatcher.java:317) at com.evermind[Oracle Application Server Containers for J2EE 10g (9.0.4.0.0)].server.http.HttpRequestHandler.processRequest(HttpRequestHandler.java:790) at com.evermind[Oracle Application Server Containers for J2EE 10g (9.0.4.0.0)].server.http.HttpRequestHandler.run(HttpRequestHandler.java:270) at com.evermind[Oracle Application Server Containers for J2EE 10g (9.0.4.0.0)].server.http.HttpRequestHandler.run(HttpRequestHandler.java:112) at com.evermind[Oracle Application Server Containers for J2EE 10g (9.0.4.0.0)].util.ReleasableResourcePooledExecutor$MyWorker.run(ReleasableResourcePooledExecutor.java:192) at java.lang.Thread.run(Thread.java:534)

is there any solution?

best regard;
kamal


Return to “Oracle Database Administration”

Who is online

Users browsing this forum: No registered users and 0 guests

cron