This forum is currently locked. You can't register or post questions at this time. (read more)

Getting error in ./runInstaller

Questions relating to Oracle Real Application Clusters (RAC) and Clusterware.

Moderator: Tim...

amitshankertripathi
Senior Member
Posts: 92
Joined: Thu Jul 22, 2010 4:25 pm
Location: India
Contact:

Getting error in ./runInstaller

Postby amitshankertripathi » Tue Apr 23, 2013 11:03 am

Hi Tim,

I am trying to install RAC clusterwere software on Virtual Machine and getting error while running ./runInstaller

Code: Select all

[grid@rac1 grid]$ ./runInstaller
Starting Oracle Universal Installer...

Checking Temp space: must be greater than 120 MB.   Actual 6384 MB    Passed
Checking swap space: must be greater than 150 MB.   Actual 2047 MB    Passed
Checking monitor: must be configured to display at least 256 colors.    Actual 16777216    Passed
Preparing to launch Oracle Universal Installer from /tmp/OraInstall2013-04-23_03-15-35PM. Please wait ...[grid@rac1 grid]$ Exception in thread "main" java.lang.UnsatisfiedLinkError: /tmp/OraInstall2013-04-23_03-15-35PM/jdk/jre/lib/i386/xawt/libmawt.so: libXext.so.6: cannot open shared object file: No such file or directory
   at java.lang.ClassLoader$NativeLibrary.load(Native Method)
   at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1753)
   at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1649)
   at java.lang.Runtime.load0(Runtime.java:769)
   at java.lang.System.load(System.java:968)
   at java.lang.ClassLoader$NativeLibrary.load(Native Method)
   at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1753)
   at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1670)
   at java.lang.Runtime.loadLibrary0(Runtime.java:822)
   at java.lang.System.loadLibrary(System.java:993)
   at sun.security.action.LoadLibraryAction.run(LoadLibraryAction.java:50)
   at java.security.AccessController.doPrivileged(Native Method)
   at java.awt.Toolkit.loadLibraries(Toolkit.java:1509)
   at java.awt.Toolkit.<clinit>(Toolkit.java:1530)
   at com.jgoodies.looks.LookUtils.isLowResolution(LookUtils.java:484)
   at com.jgoodies.looks.LookUtils.<clinit>(LookUtils.java:249)
   at com.jgoodies.looks.plastic.PlasticLookAndFeel.<clinit>(PlasticLookAndFeel.java:135)
   at java.lang.Class.forName0(Native Method)
   at java.lang.Class.forName(Class.java:242)
   at javax.swing.SwingUtilities.loadSystemClass(SwingUtilities.java:1779)
   at javax.swing.UIManager.setLookAndFeel(UIManager.java:453)
   at oracle.install.commons.util.Application.startup(Application.java:780)
   at oracle.install.commons.flow.FlowApplication.startup(FlowApplication.java:165)
   at oracle.install.commons.flow.FlowApplication.startup(FlowApplication.java:182)
   at oracle.install.commons.base.driver.common.Installer.startup(Installer.java:348)
   at oracle.install.ivw.crs.driver.CRSInstaller.startup(CRSInstaller.java:98)
   at oracle.install.ivw.crs.driver.CRSInstaller.main(CRSInstaller.java:105)



I have also run the cluvfy tool to check per-installation and got

Code: Select all

[grid@rac1 grid]$ runcluvfy.sh stage -pre crsinst -n rac1 -osdba oinstall -orainv oinstall -crshome /u01/app -fixup -verbose
Running a 64-bit JVM is not supported on this platform.


I have installed 64bit Oracle Linux

Code: Select all

[root@rac1 stage]# uname -a
Linux rac1.localdomain 2.6.39-400.21.1.el6uek.x86_64 #1 SMP Thu Apr 4 03:49:00 PDT 2013 x86_64 x86_64 x86_64 GNU/Linux

[root@rac1 stage]# cat /etc/*-release
LSB_VERSION=base-4.0-amd64:base-4.0-noarch:core-4.0-amd64:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-noarch:printing-4.0-amd64:printing-4.0-noarch
Oracle Linux Server release 6.4
Red Hat Enterprise Linux Server release 6.4 (Santiago)
Oracle Linux Server release 6.4
[root@rac1 stage]#


Java Version :-

Code: Select all

[root@rac1 stage]# java -version
java version "1.6.0_24"
OpenJDK Runtime Environment (IcedTea6 1.11.9) (rhel-1.57.1.11.9.el6_4-x86_64)
OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)



Please help to fix this issue.
Thanks

AMit Tripathi

Tim...
Site Admin
Posts: 18437
Joined: Mon Nov 01, 2004 5:56 pm
Location: England, UK
Contact:

Re: Getting error in ./runInstaller

Postby Tim... » Tue Apr 23, 2013 12:43 pm

Hi.

This is the thing to pay attention to,

"libXext.so.6: cannot open shared object file: No such file or directory"

Looks like I've not covered all the prerequisites. You should run the following command as root, the try again.

Code: Select all

yum install libXext -y


It's probably worth working through the prerequisites again to make sure you've not missed something else out also.

Cheers

Tim...
Tim...
Oracle ACE Director
Oracle ACE of the Year 2006 - Oracle Magazine Editors Choice Awards
OakTable Member
OCP DBA 7.3, 8, 8i, 9i, 10g, 11g
OCP Advanced PL/SQL Developer
Oracle Database: SQL Certified Expert
My website: http://www.oracle-base.com
My blog: http://www.oracle-base.com/blog

amitshankertripathi
Senior Member
Posts: 92
Joined: Thu Jul 22, 2010 4:25 pm
Location: India
Contact:

Re: Getting error in ./runInstaller

Postby amitshankertripathi » Wed Apr 24, 2013 4:21 pm

Hi Tim,

libXext rpm already installed on machine.

Code: Select all

[root@rac1 grid]# yum install libXext -y
Loaded plugins: refresh-packagekit, security
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package libXext.x86_64 0:1.1-3.el6 will be updated
---> Package libXext.x86_64 0:1.3.1-2.el6 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

===========================================================================================
 Package            Arch              Version                  Repository             Size
===========================================================================================
Updating:
 libXext            x86_64            1.3.1-2.el6              ol6_latest             33 k

Transaction Summary
===========================================================================================
Upgrade       1 Package(s)

Total download size: 33 k
Downloading Packages:
libXext-1.3.1-2.el6.x86_64.rpm                                      |  33 kB     00:00     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating   : libXext-1.3.1-2.el6.x86_64                                              1/2
  Cleanup    : libXext-1.1-3.el6.x86_64                                                2/2
  Verifying  : libXext-1.3.1-2.el6.x86_64                                              1/2
  Verifying  : libXext-1.1-3.el6.x86_64                                                2/2

Updated:
  libXext.x86_64 0:1.3.1-2.el6                                                             




I am getting JVM error while runing cluster verify

[grid@rac1 grid]$ runcluvfy.sh stage -pre crsinst -n host1 -verbose
Running a 64-bit JVM is not supported on this platform.
[grid@rac1 grid]$

What will next to fix this..
Thanks

AMit Tripathi

Tim...
Site Admin
Posts: 18437
Joined: Mon Nov 01, 2004 5:56 pm
Location: England, UK
Contact:

Re: Getting error in ./runInstaller

Postby Tim... » Wed Apr 24, 2013 4:43 pm

Hi.

Sorry, I meant the i686 version.

Code: Select all

yum install libXext.i686 -y


This does beg the question, what verison of the OS and Oracle software are you trying to use?

You should be installing the 64-bit version of Oracle on the 64-bit version of the OS. Somehow this does not seem to be what you are doing...

Cheers

Tim...
Tim...
Oracle ACE Director
Oracle ACE of the Year 2006 - Oracle Magazine Editors Choice Awards
OakTable Member
OCP DBA 7.3, 8, 8i, 9i, 10g, 11g
OCP Advanced PL/SQL Developer
Oracle Database: SQL Certified Expert
My website: http://www.oracle-base.com
My blog: http://www.oracle-base.com/blog

amitshankertripathi
Senior Member
Posts: 92
Joined: Thu Jul 22, 2010 4:25 pm
Location: India
Contact:

Re: Getting error in ./runInstaller

Postby amitshankertripathi » Thu Apr 25, 2013 9:11 am

Hi Tim,

I have installed libXext.i686 rpm in machine still getting same error

Code: Select all

[root@rac1 rpm]# rpm -iq libXext.i686
libXext-1.3.1-2.el6.i686
[root@rac1 rpm]#


Now i am getting this error

Code: Select all

[grid@rac1 grid]$ runcluvfy.sh stage -pre crsinst -n host1 -verbose
Running a 64-bit JVM is not supported on this platform.
Thanks

AMit Tripathi

Tim...
Site Admin
Posts: 18437
Joined: Mon Nov 01, 2004 5:56 pm
Location: England, UK
Contact:

Re: Getting error in ./runInstaller

Postby Tim... » Thu Apr 25, 2013 9:33 am

Hi.

You didn't answer my other question. Are you using the 64-bit software on the 64-OS?

Cheers

Tim...
Tim...
Oracle ACE Director
Oracle ACE of the Year 2006 - Oracle Magazine Editors Choice Awards
OakTable Member
OCP DBA 7.3, 8, 8i, 9i, 10g, 11g
OCP Advanced PL/SQL Developer
Oracle Database: SQL Certified Expert
My website: http://www.oracle-base.com
My blog: http://www.oracle-base.com/blog

amitshankertripathi
Senior Member
Posts: 92
Joined: Thu Jul 22, 2010 4:25 pm
Location: India
Contact:

Re: Getting error in ./runInstaller

Postby amitshankertripathi » Thu Apr 25, 2013 6:33 pm

HI Tim,

I am using 64 bit Oracle linux 6.3 on Virtual box which installed on windows 7 (64bit)

Code: Select all

[root@rac1 bin]# uname -a
Linux rac1.localdomain 2.6.39-400.21.1.el6uek.x86_64 #1 SMP Thu Apr 4 03:49:00 PDT 2013 x86_64 x86_64 x86_64 GNU/Linux
[root@rac1 bin]#
Thanks

AMit Tripathi

Tim...
Site Admin
Posts: 18437
Joined: Mon Nov 01, 2004 5:56 pm
Location: England, UK
Contact:

Re: Getting error in ./runInstaller

Postby Tim... » Fri Apr 26, 2013 7:44 am

Hi.

Well it does appear you have 64-bit linux, based on the kernel output.

The only time I can remember seeing this message is if:

1) You are attempting to install 64-bit Oracle on 32-bit Linux.
2) Somehow, the installer for 64-bit Oracle is attempting to use a 32-bit JVM, maybe one already installed on the VM.

I would suggest you check for any existing Java installations on the VM and remove them before attempting to run anything off the Oracle media.

If I'm honest, I would probably scrap the whole installation, redownload 64-bit Oracle Linux, redownload 64-bit Oracle and start again. :)

Cheers

Tim...
Tim...
Oracle ACE Director
Oracle ACE of the Year 2006 - Oracle Magazine Editors Choice Awards
OakTable Member
OCP DBA 7.3, 8, 8i, 9i, 10g, 11g
OCP Advanced PL/SQL Developer
Oracle Database: SQL Certified Expert
My website: http://www.oracle-base.com
My blog: http://www.oracle-base.com/blog


Return to “Oracle RAC and Clusterware”

Who is online

Users browsing this forum: No registered users and 1 guest

cron