10g Writeback issues

All posts relating to Oracle database administration.

Moderator: Tim...

Posts: 1
Joined: Mon Nov 12, 2012 2:31 am

10g Writeback issues

Postby neylon79 » Mon Nov 12, 2012 2:32 am

I'm new to OB and new to this forum. I was asked to add the writeback function to a subject area I created, so I did some research and found a couple walkthroughs. I did everything I thought I was supposed to do, but when i go into the frontend, the writeback button does not show in the column I setup.
I setup my writeback simply for making the xml simple.



you can see the setup in the backend. The subject area is FOLSUM_TEST, the connection pool is called folsum, and in the table AIF I am trying to make a simple report with account number and last comment 1. I want last comment 1 to be able to do the writeback. I set up AIF as non-cacheable. I am using an admin login so i have the "execute direct database request" ability. Last Comment 1 is VARCHAR 255 length.

Here is my XML -

<?xml version="1.0" encoding="utf-8" ?>
<WebMessageTables xmlns:sawm="com.siebel.analytics.web/message/v1">
<WebMessageTable lang="en-us" system="WriteBack" table="Messages">
<WebMessage name="WriteBack">
<writeBack connectionPool="folsum">
<insert>INSERT INTO FOLSUM_TEST.AIF ‘Last Comment 1’ (@{c1})</insert>
<update>UPDATE FOLSUM_TEST.AIF SET ‘Last Comment 1’='@{c1}' WHERE ‘Account Number’=@{c0}</update>
So I put this in the right location, and I get no writeback ability when I load the report. I am thinking that the possible problem is that the column is named Last Comment 1 instead of LAST_COMMENT_1 as one word? I put single ticks and double ticks around the column header but neither worked. I have double checked the columns label as c1 and c0,in short I am at a loss as to what could be wrong here. Oh yeah, the server is on XP and my pc is on win7. I followed these 2 walkthroughs.

http://satyaobieesolutions.blogspot.in/ ... ities.html and
http://www.eeblog.org/index.php/underst ... obiee-10g/

Thanks for your help.

Site Admin
Posts: 18437
Joined: Mon Nov 01, 2004 5:56 pm
Location: England, UK

Re: 10g Writeback issues

Postby Tim... » Mon Nov 12, 2012 9:31 am


Sorry, I'm not an OBIEE guy. I think you would get better luck posting in the OTN forum for this tech.


Oracle ACE Director
Oracle ACE of the Year 2006 - Oracle Magazine Editors Choice Awards
OakTable Member
OCP DBA 7.3, 8, 8i, 9i, 10g, 11g
OCP Advanced PL/SQL Developer
Oracle Database: SQL Certified Expert
My website: https://oracle-base.com
My blog: https://oracle-base.com/blog

Return to “Oracle Database Administration”

Who is online

Users browsing this forum: No registered users and 1 guest