El Crap-itan


In the comments from yesterday’s post, Jonathan Roden mentioned the release of El Capitan. At that point, I hadn’t even heard about it. :) Being the naive idiot I am, I jumped head long into it.

The download was about 3G, which didn’t take too long. The upgrade itself took quite a while. That included one failure. During the installation, the system rebooted, as it said it would, and I thought it was over, but it was still running Yosemite. I manually started the upgrade again by running the installer, which was sitting in the Applications folder. The second time it completed.

The first snag was my external monitor didn’t work. A bit of Googling and it seems this is not uncommon. Some people said they couldn’t get the HDMI connection to work, so I switched to a display port connection. No luck there. The “Detect Displays” button is hidden these days, but it shows up if you hold the “Options” key (see here). Apparently, this happened in a previous release, but I’ve obviously not needed it up until now. :) Anyway, that didn’t help. I just kept switching between cables, each time with a hard reboot. Eventually, it noticed the monitor on the HDMI cable and all was working fine. This does of course make me worry what is going to happen when I plug this laptop into a projector. Am I going to need several hard reboots each time before it notices the new display? :(

During the repeated reboots, I noticed how long it takes to do a hard reboot under El Capitan. I know some fanboys whould have you believe you never have to reboot an Apple device, but that it clearly not true. This is running on a 8 month old i7, with 16G RAM and a 512G flash card. It was crazy fast to reboot under Yosemite. Not so much under El Capitan. Once it’s started, I can’t tell a performance difference (at the moment), but bootup time is shocking. Much worse than Windows 7 on my crappy i5 PC at work. Some of the folks on the interwebs are claiming general performance sucks since the upgrade, even on new gear. We shall see.

Since the upgrade, the laptop doesn’t seem to turn the screen off when it’s been inactive for a while. I woke up this morning to find it had been on all night. My first thought was I had left Caffeine running, but I hadn’t. As far as I could see, there was nothing running that would cause this. I didn’t have time to figure out why. I’m marking this as a fail, because I’m forced to investigate something that was working fine before.

During my Googling for solutions to my issues, it seems lots of people are complaining about poor battery life since switching to El Capitan. My laptop is permanently plugged in when I am at home. It will be interesting to see how it copes when I travel. I won’t give this a fail yet, as I don’t have any personal experience of it, but you might want to think twice if you are a battery user. :)

Visually, I’ve not been able to tell the last few releases apart. There are allegedly new features in this release, but I’m not sure I will ever notice them. I don’t care about new eye candy that much, but I don’t see the point of giving this a new name and all that, when it feels like a minor patch.

Overall, I’m giving El Capitan a resounding fail at this point. Hopefully, Apple will take note of the complaints on the net and fix this shit soon. If you are trying to decide to switch, or not, I would say wait a while and see what Apple do in the coming weeks. Maybe you will have a different experience. Maybe not. :)




VMware Server 2.x on CentOS 5.4 problems…


Since I upgraded my desktop to CentOS 5.4 I’ve been getting loads of problems with VMware Server 2.x. I did a bit of Googling today and it turns out it’s a known problem. I followed the workaround listed at the following URL and it works fine now.


If you are struggling with VMware Server on RHEL 5.4 or any of its clones, give it a go.